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0. [bookmark: _Toc444679411]AutoModel Introduction
AutoModel is a FULLY AUTOMATIC 2D tomo-static software package, it contains following functions,
---Automatic seismic data loading,
--- Automatic first arrival picking,
--- Automatic travel time edit,
--- Automatic building initial velocity model,
--- Automatic first arrival tomography inversion,
--- Automatic high velocity interface defining,
--- Automatic datum statics calculation,
--- Automatic first arrival residual statics estimation,
--- Automatic QC and evaluation,
--- Automatic tomo-static report generating,
Suppose you have more than 100 2D lines, provide the file name of each line to AutoModel in the afternoon, and you can get the results of first arrivals, velocity models, statics and processing report for all the lines when you come back the next morning! 

AutoModel can run fully automatic or interactively step by step.

There several special technologies that ensure the success of AutoModel. 
--- Powerful automatic first arrival picking, AutoModel will do S/N ratio and will ignore those bad traces.
--- The tomography inversion result does is independent to the initial velocity model.
--- It does analysis and evaluation about the whole process, including first arrival picking quality and inversion reliability, and give PASS/FAIL judgment for each line.

There are 3 limitations in AutoModel, the maximum number of shots is 500, the smallest lateral  and vertical grid size are 10 and 5 separately. 

AutoModel is a function simplification of ToModel, for any further request or more powerful processing ability, please contact PanImaging Ltd.





1. [bookmark: _Toc444679412]AutoModel installation
[bookmark: _Toc444679413]1.1 Create directory
Create directory of AutoModel/ on your computer.

[bookmark: _Toc444679414]1.2 Copy AutoModel files
Copy the files on the flash disk or www.panimaging.com to the folder of AutoModel, you will have the following files
[image: ]
Fig 1.1 files of AutoModel

[bookmark: _Toc444679415]1.3 Install driver of AutoModel
Double click setup.bat in the directory of /SL_driver in Fig 1.1, The following window will appear.
[image: ]
Fig. 1.2 driver installation information window
Select OK, then the following window appears,


[image: ]
Fig. 1.3 License update information window

Select Apply Update, then the following window appears,
[image: ]
Fig. 1.4 License update information window

Once you installed AutoModel on one computer, you can use is for 90 days. 



2. [bookmark: _Toc444679416]Running AutoModel in batch mode
[bookmark: _Toc444679417]2.1 Starting AutoModel
Double click AutoModel.exe in Fig. 1.1, the main interface appears.
[image: ]
Fig. 2.1 AutoModel main interface

[bookmark: _Toc444679418]2.2 Define the header file
Select SEGY data loading -> File -> Open from the main interface of Fig 2.1. 
[image: ]
Fig. 2.2 defining SEGY header file window

Input file name of seismic data by clicking on Browse, check the information in the header by View, and then define the header information, save into .hs file, which will be used later by clicking on Save button. Use Open to input a header file which has been created.

[bookmark: _Toc444679419]2.3 Define the LMO parameter file
Input file name on seismic data in SEGY format, and click OK in Fig.2.2 and the data will be displayed in the following window.
[image: ]
Fig.2.3 Seismic data display window

Selesct LMO->Show LMO Frame from fig. 2.3, the default LMO parameter will be displayed like the following window.
[image: ]
Fig. 2.4 seismic data display window with default LMO parameters

Use left click to change the velocity, put the cursor on the red line and change it by left drag. Check the red box on other shots, be sure it is appropriate for all the shots, like Fig 2.5.
[image: ]
Fig. 2.5 seismic data display window with default appropriate parameters

Select LMO -> LMO setting, the LMO parameters will appear as:
[image: ]
Fig. 2.6 LMO parameters setting window
Save the LMO parameters by selecting Save.

[bookmark: _Toc444679420]2.4 Batch mode process
On the interface of Fig 2.1, input file names of seismic data, header file, LMO parameters file, parameters and click Run. It will process in batch mode.
[image: ]
Fig. 2.7 Batch mode process parameters input window
The file names of lines, which have finished inversion, will be displayed in blue color and the process is displayed in the bottom of the windows, like Fig 2.8
[image: ]
Fig. 2.8 process indicator of batch mode process

[bookmark: _Toc444679421]2.5 Batch mode process results
Suppose you have 2 lines, after defining the header file and LMO parameter file, you will have the following 4 files.
[image: ]
Fig. 2.9 files before batch process


There are will be such files after batch mode process.
[image: ]
Fig. 2.10 files after batch process

multilinesST.2mst and multilineVel.2mmd are statics and velocity models for all the lines with real coordinate which can be displayed for QC by selecting Statics -> Statics estimation -> File -> Open Multiline and Model -> Velocity model -> File -> Open Multiline from the main interface separately.

There is a directory to store all the temporary files and statics result for each line, the directory name is same as the seismic file name as shown in fig. 2.10. The files in each directory are shown in the following window.
[image: ]
Fig. 2.11 files in the temporary directory
Line_EW_1.lmo is the first arrival data after linear moveout correction.
Line_EW_1.at is the first arrival travel time with real coordinate.
Line_EW_1.2bt is the first arrival travel time with relative coordinate after transformation.
Line_EW_1_etd.2md and Line_EW_1V2000.hvi are velocity model and high velocity interface for the whole line separately.
Line_EW_1D1500V2000_TM.2st is the datum statics.
Line_EW_1D1500V2000_TM_all_d.2st is the total statics, that is the datum statics plus with the first arrival residual statics.
Line_EW_1D1500V2000_TM_all_d.cgg is the total statics which has been converted into CGG processing system format.
Line_EW_1D1500V2000_TM_all_d.cggnew is the total statics which has been converted into CGG processing system new format.
Line_EW_1D1500V2000_TM_all_d.omega.recv is the receiver statics for OMEGA processing system.
Line_EW_1D1500V2000_TM_all_d.omega.shot is the shot  statics for OMEGA processing system.


3. [bookmark: _Toc444679422]Running AutoModel step by step
If the S/N ratio is very low, the automatic picking, tomography inversion and statics estimation could not give good results in batch mode, you can run AutoModel step by step, more interactive work may be invented, such as interactive first arrival picking, more careful travel time edit for inversion and statics estimation.

[bookmark: _Toc444679423]3.1 Generating LMO data
   Select Save button in Fig. 2.5 to output first arrival data for picking after defining LMO parameters.

[bookmark: _Toc444679424]3.2 First arrivals picking
Select Picking -> File -> Open LMO data from main interface of Fig 2.1 to open the first arrival data, and following window appears.
[image: ]
Fig. 3.1 first arrival data display and picking window
Use Pick -> Semi-Auto Picking to set interactive picking options or Pick -> Automatic picking in Fig. 3.1. There several shortcut keys for interactive picking, please find it under Help menu. The first arrival data are displayed in FARR. Save the travel time into a file.







[bookmark: _Toc444679425]3.3 Coordinate transformation
Select FBT-process -> coordinate transformation at fig. 3.1, the following dialog appears,
[image: ]
Fig. 3.2 coordinate transformation
Input the file name of first arrivals with suffix of .at and the output file name will be named automatically by ToModel rules. The threshold is used to remove those traces whose S-R distance change too much after transformation.

[bookmark: _Toc444679426]3.4 First arrivals display and edit
Select Time -> File -> open to load and display the first arrival travel time from the main interface, like the following window.
[image: ]
Fig. 3.3 first arrival travel time display window
Normally, we only use traces which are within the range of shots, a value of zero will give to the traces for their travel time if they are not picked, so the zero time should be removed, and also the far offset traces are not good to near surface velocity inversion, use Edit -> Travel Time Edit to edit the travel time like the following window.
[image: ]
Fig 3.4 first arrival travel time edit window

And also you can select  [image: ], use left-click to define some control points, right-click to finish to define a polygon, those traces within the polygon will be deleted. Like the following window,
[image: ]
Fig 3.5 interactively edit by defining polygons

[bookmark: _Toc444679427]3.5 Initial velocity model building
Select Model -> Build model from Fig. 3.5 to display the travel time in X-T and define the turning point using left-click.
[image: ]
Fig 3.6 defining turning points
After the last control point defined by right-click, the initial velocity information based on delay-time method appears as the following window.
[image: ]
Fig. 3.7 initial velocity model parameters
Select OK to build the initial velocity model for inversion.

[bookmark: _Toc444679428]3.6 First arrival tomography inversion
Select Inversion -> CT Inversion from Fig. 3.6, the following tomography inversion dialog box window appears,
[image: ]
Fig. 3.8 tomography inversion dialog box

[bookmark: _Toc444679429]3.7 First arrival tomography inversion QC
Select CT QC -> Show Iterative Difference from Fig. 3.6 to display the iterative difference, like the following window, this curve should be stable and converge.
[image: ]
Fig. 3.9 iterative difference curve display
Select CT QC -> Overlay Synthetic Travel Time to overlap the synthetic travel time like the following window,
[image: ]
Fig. 3.10 Synthetic travel time display
The red and blue lines are initial and synthetic travel time separately.

Select Model -> Velocity Model -> File -> Open Ray Density from the main interface to check whether the depth of initial model is deep enough.
[image: ]
Fig 3.11 Ray density display
If the ray density is like Fig 3.11, that means the initial velocity model is not deep enough, then open the initial model and select Tools -> Model Extend -> Downward to input the thickness to make the initial model deeper.
[image: ]
Fig. 3.12 Deepen the initial velocity model
Make the initial velocity model deeper, do inversion again and get the ray density like the following window, there are no rays located in the bottom of the model, that means the thickness is enough.
[image: ]
Fig. 3.13 Ray density display

[bookmark: _Toc444679430]3.8 Extend the velocity model laterally
As the inversion result is only within the range of shots, we need to extend the model to the whole line by selecting File -> Open Velocity from Fig. 3.13 to display the inversion result like the following window,
[image: ]
Fig. 3.14 velocity model display window

Select Tools -> Extend -> Laterally, input the travel time file which contains all the shots and receivers, define the reference point and then do extending.
[image: ]
Fig. 3.15 Velocity model extending laterally parameters

[bookmark: _Toc444679431]3.9 Define high velocity interface
Select File -> Open Velocity to display the extended velocity model, and then select Tools -> Build Interface -> High Velocity Interface, the following dialog appears,
[image: ]
Fig. 3.16 Define high velocity interface dialog
You can use the icons on the interface of Fig 3.14 to modify or smooth the interface to make it more reasonable.

[bookmark: _Toc444679432]3.10 Calculate datum statics
Select Statics from the main interface, the following window appears for statics estimation,
[image: ]
Fig. 3.17 statics estimation window
Select Calculate -> datum statics, then,
[image: ]
Fig 3.18 Datum statics estimation
The velocity model and travel time file should contain all the shots and receivers for the whole line, and the high velocity interface should match with the velocity model.

[bookmark: _Toc444679433]3.11 Calculate first arrival residual statics
Select Calculate -> Residual First Arrival Statics from Fig. 3.17, then,
[image: ]
Fig. 3.19 first arrival statics estimation
For sand dune or loess plateau area, the Model curve option may be better, for other near surface type, using the Difference method. The travel time file should contain the far offset traces.
[bookmark: _Toc444679434]3.12 Static correction quality control
Select ST QC -> Open at Fig. 2.5 to input the file name of statics, then using the icon [image: ] to apply the statics to the seismic data.
Select ST QC -> Open at Fig 3.10 to input the file name of statics, the statics will be applied to the travel time and displayed in blue, while the initial travel time is displayed in red, like the following window,
[image: ]
Fig. 3.20 static correction quality control on travel time
Select ST QC -> T-FAR, for static correction quality control on the T-FAR, which is travel time under surface consistence and linear move out applied, like the following window.
[image: ]
Fig. 3.21 static correction quality control on T-FAR







[bookmark: _Toc444679435]3.13 Statics Output
Select File -> Output from Fig. 3.17 to convert the format to the seismic data processing system. 
[image: ]
Fig. 3.22 Convert into CGG format
[image: ]
Fig. 3.23 Convert into OMEGA(Promax) format
[image: ]
Fig. 3.24 Convert into CGG format with real coordinates

[bookmark: _Toc444679436]3.14 Display multi-line velocity
After batch mode processing, the velocity of each line will be merged and stored at the same directory named as multilineVel.2mmd, select File -> open multi line at Fig. 3.14 to display the multi-line velocity, like the following window.
[image: ]
Fig. 3.25 multi-line velocity display

[bookmark: _Toc444679437]3.15 Display multi-line statics
After batch mode processing, the statics of each line will be merged and stored at the same directory, named as multilineST.2mst, select File -> open multi line at Fig. 3.17 to display the multi-line statics, like the following window. You can check the match situation at the criss-cross points.
[image: ]
Fig. 3.26 multi-line statics display
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